DataPixx cannot configure digital output pixel mode


I’m trying to use a stand-alone DataPixx unit with MWorks. The DataPixx opens successfully, but fails to start:

00:01:47:  Opened DATAPixx device (ID = 17488)
00:01:47:  ERROR: Cannot configure DATAPixx digital output pixel mode: Illegal system device index (error = -1012)
00:01:47:  ERROR: Can't start iodevice (datapixx) and no alt tag specified
Extended information:
	parser_context: mw_finalize

Having read this discussion, I did not install the VPixx Software Tools.

I’ve tried on Intel and M1 macs (Intel: Mojave and Monterey; M1: Big Sur), with two different DataPixx units, and updated the firmware on one of the DataPixx devices, but I haven’t been able to get around this error.

Here’s the code I’ve been using:

var ain0 = 0
iodevice/DATAPixx datapixx (
    update_interval = 3ms
) {
    iochannel/datapixx_analog_input ain (
        channel_number = 0
        value = ain0
protocol {
    start_io_device (datapixx)
    wait (600s)

Any hints would be much appreciated.

Hi Mark,

When enabling or disabling pixel mode, the DATAPixx API appears to insist that the device is a PROPixx, VIEWPixx, or DATAPixx2. I don’t know why the original DATAPixx and the DATAPixx3 are excluded, as I can’t find any documentation indicating that they don’t support pixel mode.

In any case, I think MWorks could be a bit smarter about this. There’s an API call to test whether pixel mode is enabled. If the experiment isn’t trying to enable pixel mode, and the API call tells us it already isn’t enabled, then we shouldn’t try to disable it.

On the other hand, if you were trying to enable pixel mode, and you know that the original DATAPixx supports it, then I don’t know what the issue is. Maybe it’d be worth contacting VPixx to ask why the libdpx API supports pixel mode only on the DATAPixx2?

Chris Stawarz

Hi Chris,

Thanks for figuring this out, and for your quick reply.

I don’t know if the original DataPixx is supposed to support pixel mode. I wasn’t planning to use it, in fact, I wasn’t planning to run any video through the DataPixx at all, since it’s limited to VGA output. I was just hoping to use it as a DAQ subsystem.


Update: I checked with VPixx, and they confirmed that the original DATAPixx does not support Pixel Mode.

They suggested a work-around involving “Register Write Pixel Sync,” but since I wasn’t planning on using Pixel Mode anyway, I haven’t looked at it.

Hi Mark,

If the experiment isn’t trying to enable pixel mode, and the API call tells us it already isn’t enabled, then we shouldn’t try to disable it.

This change is now in the nightly build. When you have a chance, can you try it out and see if you can use your DATAPixx?


Hi Chris, Thanks-- that solved it!

Hi Mark,

FYI, the DATAPixx interface in the current MWorks nightly build now requires the VPixx Software Tools for Mac to be installed. Also, because the VPixx tools are currently available only as Intel binaries, you’ll need to run MWServer via Rosetta 2 in order to use the DATAPixx interface on an Apple Silicon Mac.

If you’re currently using the MWorks 0.11 release, these changes won’t affect you until you switch to a nightly build or upgrade to the next MWorks release.


Thanks for the heads-up, Chris!