"Failed to write" error

Hi Chris,

I hope you are well. We recently started experiencing the following error (see attached) when running our experiment:

ERROR: Failed to write 1000 events to data file: Cannot commit SQL transaction: disk I/O
error (10)

It corresponds to missing events in the mwk2 file.

Do you have any ideas for what could be causing this?



Screen Shot 2023-07-06 at 5.36.25 PM (1).png

Hi Simon,

The failure is happening inside SQLite. The error code (SQLITE_IOERR) indicates that “the operation could not finish because the operating system reported an I/O error”. I don’t think I’ve seen MWorks produce that error before.

My first guess is that something could be wrong with the disk that stores your event files. Maybe fire up Disk Utility and run First Aid on that disk to see if there are any obvious issues? Also, what kind of disk is it: internal, external (USB, Thunderbolt), network?

Can you also tell me what version of MWorks you’re running, and on what version of macOS?


Hi Chris,

Thanks! I think you’re right about the disk. The computer is a relatively old Mac Pro from 2013 that we have used to run many experiments on. The disk in question is the boot drive and a 256gb SSD. “First Aid” found no issues, but I downloaded a SMART utility and found out that this drive has had over 500 TB written to it in its life, well past when I would expect it to have already failed. We swapped to a new computer and did not see this problem today. We are running MWorks 0.9 and OS Big Sur 11.7.8. We initially thought it could have been correlated with an OS update, which we did last week, but we had one day after the update where everything worked. Now, looking back, I think the SSD was failing the whole time but these errors may have only started getting propagated to MWorks after the OS update. And since they were intermittent they only affected our data analysis if they happened at a critical time in the experiment (e.g. if the 1000 missed events were all eye positions, we would never notice. But if it’s a trial result, we certainly would). I took a look back at the one day the experiment worked and it had SQL errors in the mwk2 file as well.

Anyways, unless this starts happening again I think this is “case closed.”