Unable to start iodevice (keyboard)

Hi Chris,

I’m trying to connect a wire keyboard and I get the attached error, where it says mWorks cannot load the HID manager. I also tried changing the keyboard as well as the port I’m using and neither works. I have had this issue with the previous version of NightBuild as well.

Thanks in advance for your help.

Hi Setayesh,

I didn’t receive the attachment. However, the most likely issue is that MWServer hasn’t been given permission to monitor keyboard events. (Normally, a dialog box will pop up the first time you try to use a keyboard device, but it’s possible this was blocked or missed somehow.)

To fix this, go to System Preferences → Security & Privacy → Privacy. In the column on the left, select Input Monitoring. The list on the right should show MWServer with a check mark next to it (see attachment). If it’s not checked, check it. If it’s not listed at all, click the + button, then find and open MWServer in the Applications folder.

If you do all this and the keyboard still doesn’t work, please let me know!


Attachment: Screen_Shot_2021-07-28_at_10.16.47_AM.jpg (160 KB)

Thank you so much Chris, it worked :slight_smile: